electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
 Forum index » Clavia Nord Modular » Bugs
Weird CC send behaviour with midi control send
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [18 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Mon Jun 12, 2006 11:53 pm    Post subject: Weird CC send behaviour with midi control send
Subject description: Could be a bug or stupidity!
Reply with quote  Mark this post and the followings unread

Hi Guys,

I am getting something quite strange here, when I have lots of midi control send modules linked by the yellow send/receive pairs the G2 starts to loose resolution on the CC's it sends!

I have included a large controller patch all the CC sends on this patch only send a few cc messages per second.

I have set up a couple of modules to show this, they are called noSend and send and are on the right of the VA section.

NoSend is not linked and send is linked, I have mapped the knobs to the filter 1 page knobs 7 and 8 on the g2.

If you run a midi monitor app (like midiox) and twiddle the two knobs (or do it in the editor) you can see the problem.

Does anyone have any idea whats going on here?

Cheers

Andy


MiniMoog Ctrl_3.pch2
 Description:
Patch showing CC sending loosing resolution

Download
 Filename:  MiniMoog Ctrl_3.pch2
 Filesize:  8.16 KB
 Downloaded:  872 Time(s)

Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20681
Location: The Netherlands, Enschede
Audio files: 156
G2 patch files: 318

PostPosted: Tue Jun 13, 2006 12:52 pm    Post subject: Re: Weird CC send behaviour with midi control send
Subject description: Could be a bug or stupidity!
Reply with quote  Mark this post and the followings unread

BobTheDog wrote:

Does anyone have any idea whats going on here?


Maybe you exceed the capacity of the MIDI line, does your monitor program put time stamps on the messages ?

Another possibility would be that you exceed the MIDI processing capabilities of the G2, timestamps would be very handy to determine what happens.

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Tue Jun 13, 2006 11:30 pm    Post subject: Reply with quote  Mark this post and the followings unread

Hi Jan,

I dont't think it is anything to do with the capacity of the midi line as it is not being overloaded.

The problem is that the CC send module sends limited messages if a wire is connected to the logic send input even when the logic signal is at 0. If I disconnect the wire to the logic send input the module then send the correct number of messages.

Did you try the patch?

Cheers

Andy
Back to top
View user's profile Send private message
ian-s



Joined: Apr 01, 2004
Posts: 2578
Location: Auckland, New Zealand
Audio files: 42
G2 patch files: 611

PostPosted: Wed Jun 14, 2006 12:43 am    Post subject: Reply with quote  Mark this post and the followings unread

I never found a use for those logic in/outs, so I never connect them.
Back to top
View user's profile Send private message
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Wed Jun 14, 2006 12:57 am    Post subject: Reply with quote  Mark this post and the followings unread

Hi Ian,

They are useful for sending all the cc's when you change variation or load the patch, this works fine in the patch I posted, apart from the undesired side-effect of making the controls useless!

Cheers

Andy
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20681
Location: The Netherlands, Enschede
Audio files: 156
G2 patch files: 318

PostPosted: Wed Jun 14, 2006 1:09 am    Post subject: Reply with quote  Mark this post and the followings unread

BobTheDog wrote:
They are useful for sending all the cc's when you change variation or load the patch,


I was just about finished to type a post saying just that Very Happy

Didn't check the patch yet, but I'll mark the thread un-read for when I get back from work. I'll re-read your post then as well, before saying silly things now ...

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Wed Jun 14, 2006 1:28 am    Post subject: Reply with quote  Mark this post and the followings unread

Nice one Jan.

Cheers

Andy
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20681
Location: The Netherlands, Enschede
Audio files: 156
G2 patch files: 318

PostPosted: Wed Jun 14, 2006 10:56 am    Post subject: Reply with quote  Mark this post and the followings unread

Ok ... this is fishy ... and it shouldn't be that, there is no other disturbing MIDI traffic at all and it sends much less values indeed. Seems a bug to me, or at least an interesting phenomenon, like fun for Clavia to look into Very Happy

Funny thing is that when I strip the patch down to leave just one CC send in (and the Status module) the problem doesn't seem to be present or much less present at least. As if the whole chain of CC sends is evaluated even when only the last one changes value and nothing happens on the yellow lines.

Edit, forgot : when I leave in all the modules but break the yellow hain to have onl the last CC send connected to the Status module the drop in the number of values sent is still present, so it seems related to the number of CC send modules, and not so much to how they are chained.

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Wed Jun 14, 2006 11:54 am    Post subject: Reply with quote  Mark this post and the followings unread

Hi Jan,

Do you think I should report it to Clavia then?

Cheers

Andy
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20681
Location: The Netherlands, Enschede
Audio files: 156
G2 patch files: 318

PostPosted: Wed Jun 14, 2006 12:36 pm    Post subject: Reply with quote  Mark this post and the followings unread

Seems a good idea to me to report it to Clavia, yes, I had meant to type that ... hmm another thing I forgot ... wonder where my brains are ...
_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Wed Jun 14, 2006 1:07 pm    Post subject: Reply with quote  Mark this post and the followings unread

Ok Done it, lets see what they have to say.

Cheers

Andy
Back to top
View user's profile Send private message
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Thu Jun 15, 2006 12:14 am    Post subject: Reply with quote  Mark this post and the followings unread

Hi Guys,

I just got this in response from Clavia:


Hello, thanks for your report, I will take a look at this. For the time
being there are no updates planned for the G2 so im afraid I cant give you
any hint when this can or will possibly be solved, take care

Alexander Frodinger
Clavia Technical Support
support@clavia.se
www.clavia.se
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20681
Location: The Netherlands, Enschede
Audio files: 156
G2 patch files: 318

PostPosted: Thu Jun 15, 2006 3:17 am    Post subject: Reply with quote  Mark this post and the followings unread

But at least it sounds like a confirmation that its a bug ...
_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Thu Jun 15, 2006 3:26 am    Post subject: Reply with quote  Mark this post and the followings unread

Looks like it.

I will change the patch to move more of the modules into the FX area to see if that helps.

Cheers

Andy
Back to top
View user's profile Send private message
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Fri Jun 16, 2006 11:42 pm    Post subject: Reply with quote  Mark this post and the followings unread

Hi Jan,

The problem is definately when the modules are linked.

I have included two patches.

bugtest_unlinked : Here we can see the resoultion of the midi send modules are fine, there are two being set by the lfo we get lots of resolution.

bugtest_linked : Here it is bad, the resolution is terrible. But it get worse. If you turn the lfo control off with the switch and twiddle the knob on the u-manual control (right of the lfo) you can see the resolution is fine. If you twiddle the linked l-manual control you don't get anything at all, the G2 is sending nothing!

cheers

Andy.


bugtest_linked.pch2
 Description:

Download
 Filename:  bugtest_linked.pch2
 Filesize:  5.33 KB
 Downloaded:  826 Time(s)


bugtest_unlinked.pch2
 Description:

Download
 Filename:  bugtest_unlinked.pch2
 Filesize:  4.85 KB
 Downloaded:  784 Time(s)

Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20681
Location: The Netherlands, Enschede
Audio files: 156
G2 patch files: 318

PostPosted: Sat Jun 17, 2006 6:33 am    Post subject: Reply with quote  Mark this post and the followings unread

Andy,

after testing I can confirm what you wrote and it seems like a pretty accurate problem description to me.

I'm about to move this thread to bugs section, unless some one has problems with that.

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
BobTheDog



Joined: Feb 28, 2005
Posts: 3869
Location: England
Audio files: 32
G2 patch files: 15

PostPosted: Sat Jun 17, 2006 10:06 am    Post subject: Reply with quote  Mark this post and the followings unread

Hi Andy,

I have no problem, it seems like the place it should be.

Cheers

Andy
Back to top
View user's profile Send private message
Nodular



Joined: May 05, 2005
Posts: 77
Location: Milano
G2 patch files: 7

PostPosted: Mon Oct 30, 2006 5:29 am    Post subject: Reply with quote  Mark this post and the followings unread

Using my G2s a lot for midi controlling I've observed this bad limitation many times.
Please note that there's sort of workaround for this.
The problem seems to be much less present if you turn patch to monophonic, or you move as many as possible ctrl send modules into FX area (that is monophonic).
Still this is an annoying bug in my opinion.

ciao
Back to top
View user's profile Send private message MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [18 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » Bugs
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use