electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
 Forum index » Clavia Nord Modular » NM Classic (NM1 or G1)
Nord Modular Editor on OS X using wine
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [15 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
tinez



Joined: Aug 21, 2014
Posts: 5
Location: Poland, Katowice

PostPosted: Thu Aug 28, 2014 3:38 pm    Post subject: Nord Modular Editor on OS X using wine
Subject description: a lighter way to run NME
Reply with quote  Mark this post and the followings unread

Hi everyrone. Since this is my first post - a short introduction. I play bass, piano and have a lot of love for synths. Professionally i'm a software developer.

I'm also a very happy owner of G1 since about 3 months. I used to run NMEditor using wine on linux. If you're not familiar with wine you can check their website http://winehq.org. It's not a virtual machine and it's not emulation - it's rewriting of win$ libraries on different operating systems. That means when you run NME on wine, you run it like a native OS X app.

I was pretty angry to find out that running NME on wine on OS X didn't work. It turned out, there was no sysex message handlers implemented in wines coreaudio driver. Two evenings later i have a patch and successfully run NME on wine on OS X Wink I'm pretty sure that G2 editor will also work - I need some brave volunteers to check that Very Happy

Ok, here's what you gotta do to make things work:
1. install brew (http://brew.sh/), remember to run brew doctor and brew update afterwards
2. edit /usr/local/Library/Formula/wine.rb file in your favorite text editor (or you can just run "brew edit wine" in terminal)
3. find section that looks like this:
Code:
stable do
...
    resource 'mono' do:
    ...
    end
end

and append url to my patch like this:
Code:
stable do
...
    resource 'mono' do:
    ...
    end
    patch do
        url "https://raw.githubusercontent.com/tinez/patches/master/wine/winecoreaudio_sysex.patch"
        sha256 'a4a91359ecce2a3fbaf559c692f374e9c6bcdbec50b75c01868dd26f6214fa33'
    end
end

4. brew install --build-from-source wine
5. download win$ version of NMEditor
6. run it by typing "wine Nord Modular Editor File Name.exe" (i can't remember the exact filename... ;P)

If you don't trust me, you can take a look at the patch. Just go ahead and open it in your browser. If you want to try this solution out, but something doesn't work for you, write me a PM, i'll be glad to help. Finally - happy patch editing!

Last edited by tinez on Sun Nov 30, 2014 4:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
johann martinus



Joined: Sep 22, 2014
Posts: 1
Location: Austria

PostPosted: Mon Sep 22, 2014 11:12 am    Post subject: thank you so much for this Reply with quote  Mark this post and the followings unread

I have been searching for this solution for years!
works fine! in the beginning it didn't work (always lost connection).
then i disabled the midiclk on the midioutput of the midicard. now its stable and awesome.

thx again!!!
Back to top
View user's profile Send private message
varice



Joined: Dec 29, 2004
Posts: 731
Location: Northeastern shore of Toledo Bend
Audio files: 22
G2 patch files: 49

PostPosted: Mon Sep 22, 2014 4:45 pm    Post subject: Reply with quote  Mark this post and the followings unread

welcome to the electro-music forum johann martinus Exclamation

Congratulations on getting the G1 Editor to work on your OS X computer Exclamation

_________________
varice
Back to top
View user's profile Send private message
tinez



Joined: Aug 21, 2014
Posts: 5
Location: Poland, Katowice

PostPosted: Tue Sep 23, 2014 1:12 pm    Post subject: Reply with quote  Mark this post and the followings unread

Glad I could help! I thought more people had problem running g1 editor on OSX though. Then I would maybe try to upstream my patch to wine project so it would be merged into official version of application. But then again, if no one cares, why bother Wink
Back to top
View user's profile Send private message
dc



Joined: Sep 30, 2014
Posts: 1
Location: chicago

PostPosted: Tue Sep 30, 2014 1:53 pm    Post subject: Reply with quote  Mark this post and the followings unread

this is amazing! works very well!

my micro mod had been sitting in storage for ages. happy to have it back in my set up.

thanks so much for the work, tinez.

- dc
Back to top
View user's profile Send private message
snaakmans



Joined: Nov 13, 2014
Posts: 2
Location: den haag

PostPosted: Thu Nov 13, 2014 4:22 pm    Post subject: Reply with quote  Mark this post and the followings unread

Thanks for the walkthrough and patch! It works like a charm.

Nme seems to be working well, as far as i can see (with wine on os10.8.5)!
except connecting to the synth doesnt seem to happen.
It looks like my midi interface (midisport1x1) is being picked up by NME, though.

What i wonder, is this actually the patch functioning fine and is the problem in Modular Editor or my midi interface?
Any other experiences or clues?

Thanks for the great work!
Back to top
View user's profile Send private message
tinez



Joined: Aug 21, 2014
Posts: 5
Location: Poland, Katowice

PostPosted: Sun Nov 16, 2014 1:45 pm    Post subject: Reply with quote  Mark this post and the followings unread

Someone else PMed me with similar issue. I've made him a check list. I'll just repaste it here Smile

1. make sure you have appropriate midi device selected in nord modular editor - go to "Setup->Midi" and choose your interface

2. did you modify wine.rb to include my patch? you can double check that by typing "cat /usr/local/Library/Formula/wine.rb | grep winecoreaudio_sysex.patch" in console. It should print out the url line.

3. did you "brew install wine" AFTER modyfing wine.rb? if you're not sure than run "brew remove wine && brew install wine" to reinstall wine

4. make sure you have your cables right (inserted to PC in/out ports of Nord), we all have bad days Wink

Everything should work out of the box. If your midi interface works with normal mac os x apps then there's no reason why it shouldn't work with wine.

cheers, tinez
Back to top
View user's profile Send private message
snaakmans



Joined: Nov 13, 2014
Posts: 2
Location: den haag

PostPosted: Mon Nov 17, 2014 5:30 am    Post subject: Reply with quote  Mark this post and the followings unread

Thanks for getting back on this..

I ran down the check list, everything seems to be in order.
Unfortunately though, no luck on "seeing" the modular though, it stays stuck on "still looking…".

I'm also trying other midi interfaces.
Until now, no luck on a 1x1 midisport, nor on my MOTU traveler's midi ports.

I remember from back in the day that you had to run NME in some kind of (WIN98?) compatibility mode, else it wouldn't be able to connect.
Any clue how this relates to operation using WINE?

Another thing, this might be completely normal though, just posting it to be sure.. I get a lot of these messages in the terminal:
fixme:midi:MIDIIn_MessageHandler Starting System Exclusive
fixme:midi:MIDIIn_MessageHandler Ending System Exclusive

Many thanks!
Back to top
View user's profile Send private message
tinez



Joined: Aug 21, 2014
Posts: 5
Location: Poland, Katowice

PostPosted: Mon Nov 17, 2014 9:50 am    Post subject: Reply with quote  Mark this post and the followings unread

If you can see this message in your terminal, then you don't have my patch Smile
That can mean two things - something went bad while patching wine.rb or something went wrong in the middle of patching wine sources using my patch. Could you please PM me your wine.rb file? I wont have access to my mac for a couple of days so I gotta rely on your feedback to fix that Wink
Back to top
View user's profile Send private message
tinez



Joined: Aug 21, 2014
Posts: 5
Location: Poland, Katowice

PostPosted: Sun Nov 30, 2014 3:59 pm    Post subject: Reply with quote  Mark this post and the followings unread

ok, after some pms with snaakmans we've figured out the problem. if you have installed wine, but somehow it didn't work, please remove it using "brew remove wine" and then install using "brew install --build-from-source wine" command. it turns out homebrew had some precompiled versions of wine available so my patch have never been added to the binary.
Back to top
View user's profile Send private message
jonah



Joined: Sep 29, 2012
Posts: 15
Location: us

PostPosted: Fri Dec 05, 2014 12:42 pm    Post subject: Reply with quote  Mark this post and the followings unread

oh wow. Smile i hope this works for me, i'll have to try it later today.

but just as exciting to me, am i right in thinking this will let anything wine work with sysex, like sound diver!

i'm sure there's even more useful sysex stuff i've forgotten about because it's been so long since i could use it...it's funny i wonder in 20 years how much of the software i run will be 30+ years old. Smile

imo this should definitely be part of the official version. Smile

thanks for the effort and sharing!
Back to top
View user's profile Send private message
mattp



Joined: Apr 30, 2005
Posts: 28
Location: Thame, UK
G2 patch files: 2

PostPosted: Sat Dec 06, 2014 8:14 am    Post subject: Reply with quote  Mark this post and the followings unread

Thank you so much that's fantastic. Works a treat.

I did have to download and install https://xquartz.macosforge.org

But I was prompted to do that and the whole process was so easy.
Back to top
View user's profile Send private message
jonah



Joined: Sep 29, 2012
Posts: 15
Location: us

PostPosted: Sun Dec 07, 2014 12:24 pm    Post subject: Reply with quote  Mark this post and the followings unread

never mind, source forge glitch, fixed. installing now. Smile
Back to top
View user's profile Send private message
secretkillerofnames



Joined: Mar 25, 2013
Posts: 64
Location: Brisbane

PostPosted: Sat Dec 13, 2014 2:58 am    Post subject:   Reply with quote  Mark this post and the followings unread

Awesome!
Tried this with the "build-from-source" command and it looks to be working great!
Thanks very much! Very Happy
Is there a way to create a shortcut for this to execute from Finder - as opposed to using Terminal every time?
Back to top
View user's profile Send private message
donpachi



Joined: Jul 16, 2009
Posts: 61
Location: Marburg
Audio files: 2

PostPosted: Sat Dec 13, 2014 3:56 am    Post subject:   Reply with quote  Mark this post and the followings unread

Working nicely on 10.9.5!
Thank you tinez Cool
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [15 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » NM Classic (NM1 or G1)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use