electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
Live streaming at radio.electro-music.com

  host / artist show at your time
  Faux Pas Quartet and friends Music From Last Thursday
Please visit the chat
 Forum index » Clavia Nord Modular » Bugs
Example showing a problem in ClockDiv Module V1.32 demo
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [9 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
bantri



Joined: May 15, 2005
Posts: 149
Location: brazil
Audio files: 1
G2 patch files: 32

PostPosted: Tue May 17, 2005 9:14 am    Post subject: Example showing a problem in ClockDiv Module V1.32 demo Reply with quote  Mark this post and the followings unread

Here´s the example

[note Blue Hell : Moved this into the general discussion area as it's not a building block]


[note mosc : Moved this into the bugs forum started as a result of this topic - see below.]


ClockDivBugV132.pch2
 Description:

Download
 Filename:  ClockDivBugV132.pch2
 Filesize:  1.1 KB
 Downloaded:  667 Time(s)

Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20728
Location: The Netherlands, Enschede
Audio files: 158
G2 patch files: 318

PostPosted: Tue May 17, 2005 11:56 am    Post subject: Reply with quote  Mark this post and the followings unread

What is the problem exactly, or is it in the demo software only maybe ?

Jan.
Back to top
View user's profile Send private message Visit poster's website
bantri



Joined: May 15, 2005
Posts: 149
Location: brazil
Audio files: 1
G2 patch files: 32

PostPosted: Tue May 17, 2005 12:17 pm    Post subject: Clock Divider problem Reply with quote  Mark this post and the followings unread

Using the software only v 1.32 demo what happens is:

If you use the clock divider in gated mode it works correctly sending pulses to the 8 counter making it present sequential leds but when you switch it to toggled mode it should do the same once the counter increments in the up clock edge but instead it outputs a spurious signal that make the 8 counter blink the leds completely at random
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20728
Location: The Netherlands, Enschede
Audio files: 158
G2 patch files: 318

PostPosted: Tue May 17, 2005 12:27 pm    Post subject: Reply with quote  Mark this post and the followings unread

Ok, it doesn't do so in the real thing but I can reproduce it in the demo software - seems a bug (assuming it's not a display only phenomenon, which I didn't check).

Jan.
Back to top
View user's profile Send private message Visit poster's website
LLR3



Joined: Sep 10, 2004
Posts: 41
Location: Helsinki Finland

PostPosted: Tue May 17, 2005 4:22 pm    Post subject: Re: Clock Divider problem Reply with quote  Mark this post and the followings unread

bantri wrote:
Using the software only v 1.32 demo what happens is:

If you use the clock divider in gated mode it works correctly sending pulses to the 8 counter making it present sequential leds but when you switch it to toggled mode it should do the same once the counter increments in the up clock edge but instead it outputs a spurious signal that make the 8 counter blink the leds completely at random


I already notified Clavia (05/05/05[!]) on this matter.

Should we perhaps have a group for posting bug reports already sent to Clavia? I think one bug report for one bug should be enough! Or maybe if we had the bug report / discussion group we wouldn´t even have to send them any reports but instead they could come over and read the reports from here!

*LLR3
Back to top
View user's profile Send private message
mosc
Site Admin


Joined: Jan 31, 2003
Posts: 17624
Location: Allentown, PA
Audio files: 125
G2 patch files: 60

PostPosted: Wed May 18, 2005 6:50 am    Post subject: Reply with quote  Mark this post and the followings unread

Good suggestions. I created a Bugs forum under Clavia Nord Modular. Hopefully, there will be very few entries here.
_________________
--Howard
my music and other stuff
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
LLR3



Joined: Sep 10, 2004
Posts: 41
Location: Helsinki Finland

PostPosted: Wed May 18, 2005 4:42 pm    Post subject: Reply with quote  Mark this post and the followings unread

Here´s the one I sent to Clavia:

---

Toggled mode on ClkDiv does not seem to function correctly on G2 Demo 1.30. Try it!

I didn´t test this on 1.32 Demo though.

And I haven´t yet (since discovering the fault on the demo) especially tried this on the real thing, but I can´t recall having any such problems...

---

Last time I reported a problem to Clavia, they obviously didn´t even try recreating the symptoms but instead I was immediately asked to give a more detailed description of the (very simple) problem. This time I didn´t want to waste any extra time describing another very obvious bug so I simply asked them to try it out themselves!

*LLR3
Back to top
View user's profile Send private message
mosc
Site Admin


Joined: Jan 31, 2003
Posts: 17624
Location: Allentown, PA
Audio files: 125
G2 patch files: 60

PostPosted: Thu May 19, 2005 7:53 am    Post subject: Reply with quote  Mark this post and the followings unread

I can understand them asking for an explaination. "Doesn't operate properly - try it". Is not specific or descriptive. This is one reason some people argued for not opening a bug forum here.

Reporting a bug requires considerable effort. One must indicate all of the appropriate things:

What OS on the synth
What OS on the computer
What version of the editor
Describe the problem in detail
If possible, submit a very simple patch that isolates and identifies the problem.

Otherwise, the developers can spend a great deal of time trying to identify the problem. I have been on several beta testing programs for different manufactures, including Clavia. Several bugs I have identified turn out not to be bugs but just a case of lack of understanding of the operation on my part.

_________________
--Howard
my music and other stuff
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
LLR3



Joined: Sep 10, 2004
Posts: 41
Location: Helsinki Finland

PostPosted: Thu May 19, 2005 3:31 pm    Post subject: Reply with quote  Mark this post and the followings unread

mosc wrote:
I can understand them asking for an explaination. "Doesn't operate properly - try it". Is not specific or descriptive. This is one reason some people argued for not opening a bug forum here.


Well, now that we have this forum, one PROPER bug report (per bug!) should be enough. Earlier you could never be sure if everybody else had already reported the same bug - but now things have changed!

I sent my "try it" report because when I sent my earlier, well detailed report (on another problem) Clavia did not even bother trying to duplicate the symptoms before asking for more details. And this time the problem was even more self-explanatory.

We don´t get paid for doing beta testing for Clavia (at least I don´t!), so I think they should do most of the hard work. "Try it" -sort of reports naturally shouldn´t be sent any more as we now have this forum and are more aware of which bugs have already been spotted.

*LLR3
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [9 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » Bugs
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use