electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
 Forum index » Clavia Nord Modular » Nord Modular G2 Discussion
Finally!!! Nord Modular G2 OS & G2 Editor 1.62 (UPDATED)
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 7 [151 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Goto page: 1, 2, 3, 4, 5, 6, 7 Next
Author Message
boxcolony



Joined: Apr 30, 2008
Posts: 44
Location: Philippines
G2 patch files: 1

PostPosted: Wed Jan 28, 2009 6:11 am    Post subject:  Finally!!! Nord Modular G2 OS & G2 Editor 1.62 (UPDATED) Reply with quote  Mark this post and the followings unread

The Nord Modular G2 OS and the G2 Editor has just been updated to version 1.62 to fix the bugs.

Check out clavia's front page.

http://www.nordkeyboards.com/main.asp

Mabuhay,

-eric-

Last edited by boxcolony on Thu Feb 05, 2009 10:05 am; edited 1 time in total
Back to top
View user's profile Send private message
JLS



Joined: Nov 05, 2005
Posts: 426
Location: Czech
Audio files: 27
G2 patch files: 275

PostPosted: Wed Jan 28, 2009 6:44 am    Post subject: Reply with quote  Mark this post and the followings unread

Hmm

Bad news - only vista and mac support Sad

_________________
Sorry my bad English Smile

http://jlswbs.blogspot.com
http://jlswbs.wordpress.com
http://jls.wbs.cz
Back to top
View user's profile Send private message Visit poster's website
Keysandslots



Joined: Aug 18, 2006
Posts: 266
Location: Mississauga, Ontario

PostPosted: Wed Jan 28, 2009 7:06 am    Post subject: Reply with quote  Mark this post and the followings unread

The page mentions Vista support but I do not think it is Vista and Mac only.

Randy
Back to top
View user's profile Send private message
ark



Joined: Mar 06, 2008
Posts: 676
Location: New Jersey
Audio files: 11
G2 patch files: 31

PostPosted: Wed Jan 28, 2009 8:06 am    Post subject: Reply with quote  Mark this post and the followings unread

It's not. I just installed it on my XP machines and it works fine. I think the earlier poster meant that it didn't add anything beyond Vista and Mac support.

Incidentally, there is one wrinkle that I did not see mentioned in the documentation.

I installed the 1.60 editor package as instructed, and it removed the device driver as it said it would.

I then installed the new device driver and tried the editor. No problem.

Then I uninstalled the 1.40 editor. After that, the 1.60 editor stopped working.

Installing the 1.60 editor a second time fixed the problem.

On my other computer, I unstalled the 1.40 editor first, then installed the 1.60 package. Again it uninstalled the driver and I installed the new one. This time everything worked perfectly.

So I suggest that if you intend to install the new package, remove the 1.40 editor first.
Back to top
View user's profile Send private message Visit poster's website
JLS



Joined: Nov 05, 2005
Posts: 426
Location: Czech
Audio files: 27
G2 patch files: 275

PostPosted: Wed Jan 28, 2009 8:56 am    Post subject: Reply with quote  Mark this post and the followings unread

sorry my bad english

I mean only this news is bad news. Not new modules, new function, nothing !

Sad

_________________
Sorry my bad English Smile

http://jlswbs.blogspot.com
http://jlswbs.wordpress.com
http://jls.wbs.cz
Back to top
View user's profile Send private message Visit poster's website
CoolAngel



Joined: Jan 28, 2009
Posts: 6
Location: Siracusa

PostPosted: Wed Jan 28, 2009 9:15 am    Post subject: Nord Editor 1.6 bug? Reply with quote  Mark this post and the followings unread

Hello to all,
are the new forum, I have now installed the new driver and the new editor for my G2 is on XP or on Vista (2 computers where it was not installed the driver and the editor of the previous G2) .. and I noticed in both cases that if you open the editor for the first time everything works fine, but if you close the editor and reopened several times this is blocked and you turn off and on the G2 Crying or Very sad . Someone had this problem? Thank you

P.S. Sorry my bad English
Back to top
View user's profile Send private message
ark



Joined: Mar 06, 2008
Posts: 676
Location: New Jersey
Audio files: 11
G2 patch files: 31

PostPosted: Wed Jan 28, 2009 9:28 am    Post subject: Reply with quote  Mark this post and the followings unread

I've noticed the same problem. At least power-cycling the G2 fixes it. I've sent email to Clavia about it; perhaps others should do the same.
Back to top
View user's profile Send private message Visit poster's website
CoolAngel



Joined: Jan 28, 2009
Posts: 6
Location: Siracusa

PostPosted: Wed Jan 28, 2009 9:35 am    Post subject: Reply with quote  Mark this post and the followings unread

Perfect ark .. then it is not only my problem, we hope that Clavia solve the problem soon. Thanks for your response

P.S. I too have just sent an email to Clavia

Last edited by CoolAngel on Wed Jan 28, 2009 9:40 am; edited 1 time in total
Back to top
View user's profile Send private message
Tim Kleinert



Joined: Mar 12, 2004
Posts: 1042
Location: Zürich, Switzerland
Audio files: 6
G2 patch files: 214

PostPosted: Wed Jan 28, 2009 9:35 am    Post subject: Reply with quote  Mark this post and the followings unread

JLS wrote:
sorry my bad english

I mean only this news is bad news. Not new modules, new function, nothing !

Sad

I'd already be satisfied with an update which made some of the existing functions properly function. Laughing

Well...

(...Reaktor looks nice... Laughing)

_________________
beer
Back to top
View user's profile Send private message
ark



Joined: Mar 06, 2008
Posts: 676
Location: New Jersey
Audio files: 11
G2 patch files: 31

PostPosted: Wed Jan 28, 2009 9:39 am    Post subject: Reply with quote  Mark this post and the followings unread

CoolAngel wrote:
Perfect ark .. then it is not only my problem, we hope that Clavia solve the problem soon. Thanks for your response
You're welcome.

Incidentally, you do not have to turn the G2 off. You can also disconnect and reconnect the USB cable.
Back to top
View user's profile Send private message Visit poster's website
peterkadar



Joined: Jan 11, 2009
Posts: 153
Location: Toronto, Canada
G2 patch files: 1

PostPosted: Wed Jan 28, 2009 9:41 am    Post subject: Reply with quote  Mark this post and the followings unread

I'm just glad that there's a life for my G2 if and when my current windows and macs (an old Powerbook and the first Mac Mini) bite the dust. Now I might pick up a 2nd G2 if I find one for a good price in Toronto.
Back to top
View user's profile Send private message
CoolAngel



Joined: Jan 28, 2009
Posts: 6
Location: Siracusa

PostPosted: Wed Jan 28, 2009 9:44 am    Post subject: Reply with quote  Mark this post and the followings unread

Yes, I too have noticed that just simply disconnect and reconnect the USB cable, but still a bug that I hope Clavia solve ...Thanks ark Wink
Back to top
View user's profile Send private message
ark



Joined: Mar 06, 2008
Posts: 676
Location: New Jersey
Audio files: 11
G2 patch files: 31

PostPosted: Wed Jan 28, 2009 10:05 am    Post subject: Reply with quote  Mark this post and the followings unread

Can someone with the beta version check whether it has the same problem?

Also, is there a safe way of going back to 1.40? There doesn't seem to be any advantage to 1.60 unless you have Vista or an Intel Mac.
Back to top
View user's profile Send private message Visit poster's website
purusha



Joined: Mar 13, 2008
Posts: 131
Location: Ilkley

PostPosted: Wed Jan 28, 2009 10:45 am    Post subject: Reply with quote  Mark this post and the followings unread

It was also a problem on the beta. I informed nord on that some time ago.

Not ideal, but not the worst issue I've ever come across either.

I notice the USB driver is shared with other nord keyboards. Maybe we'll be able to use any updates on that side of things in future?

_________________
OVNI Soundcloud Purusha Soundcloud
Back to top
View user's profile Send private message
buzzr



Joined: Dec 13, 2007
Posts: 360
Location: portland
Audio files: 1
G2 patch files: 1

PostPosted: Wed Jan 28, 2009 11:11 am    Post subject: Reply with quote  Mark this post and the followings unread

Hey, good news!!!!! This is it for the G2 folks........

Now, onto other ventures. Hopefully we see something new at Messe, but now I highly doubt it.

I will wait until april before I buy the Pacarana or just learn Reaktor.

I hope they come out with something new but I'm dreaming at this point Crying or Very sad
Back to top
View user's profile Send private message
GovernorSilver



Joined: Apr 26, 2004
Posts: 1343
Location: Washington DC Metro
G2 patch files: 1

PostPosted: Wed Jan 28, 2009 12:15 pm    Post subject: Reply with quote  Mark this post and the followings unread

More info on the update is here:

http://www.nordkeyboards.com/main.asp?tm=Products&clpm=Nord_Modular_G2&clnlm=Software_Updates

_________________
Current and recent work on Soundcloud

Some old stuff on VIRB
Back to top
View user's profile Send private message Visit poster's website
purusha



Joined: Mar 13, 2008
Posts: 131
Location: Ilkley

PostPosted: Wed Jan 28, 2009 1:59 pm    Post subject: Reply with quote  Mark this post and the followings unread

BTW - anyone know if any of the other Nord synths which use the USB driver suffer from anything similar to the bug described?
_________________
OVNI Soundcloud Purusha Soundcloud
Back to top
View user's profile Send private message
jksuperstar



Joined: Aug 20, 2004
Posts: 2492
Location: Denver
Audio files: 1
G2 patch files: 18

PostPosted: Wed Jan 28, 2009 9:51 pm    Post subject: Reply with quote  Mark this post and the followings unread

This shared driver news is a VERY good thing, IMHO. It means that even if the G2 isn't supported by future software updates, it may still get driver updates when more popular products get them. It also probably reduces the load on Clavia to support many drivers, which could make them more responsive to OS support issues. That's great for everyone involved. This, along with the 64bit release, explains why it took a full year to finish.
Back to top
View user's profile Send private message Visit poster's website
doctorno



Joined: Apr 10, 2007
Posts: 46
Location: Erkelenz, Germany
G2 patch files: 8

PostPosted: Thu Jan 29, 2009 10:31 am    Post subject: Thank you, Clavia! Reply with quote  Mark this post and the followings unread

We have waited for more than a year and finally there is the update of the Nord Modular G2 driver, OS and software. And all that some people have to do is to complain. I would like to say "thank you" to Clavia. They have offered another update to make the editor work better with Vista and with Intel Macs - great! What more do you expect? It is for free. It works. And it is an update for a product that does not seem to be very profitable for Clavia.
Back to top
View user's profile Send private message
ark



Joined: Mar 06, 2008
Posts: 676
Location: New Jersey
Audio files: 11
G2 patch files: 31

PostPosted: Thu Jan 29, 2009 10:41 am    Post subject: Re: Thank you, Clavia! Reply with quote  Mark this post and the followings unread

doctorno wrote:
They have offered another update to make the editor work better with Vista and with Intel Macs - great! What more do you expect? It is for free. It works. And it is an update for a product that does not seem to be very profitable for Clavia.
Indeed. Nevertheless, I will be happier if they fix the bug that I reported (both to them and to the list). With a little luck, the bug will turn out to be in the driver, so they will have to fix it for all their products Smile
Back to top
View user's profile Send private message Visit poster's website
doctorno



Joined: Apr 10, 2007
Posts: 46
Location: Erkelenz, Germany
G2 patch files: 8

PostPosted: Thu Jan 29, 2009 11:54 am    Post subject: Re: Thank you, Clavia! Reply with quote  Mark this post and the followings unread

ark wrote:
doctorno wrote:
They have offered another update to make the editor work better with Vista and with Intel Macs - great! What more do you expect? It is for free. It works. And it is an update for a product that does not seem to be very profitable for Clavia.
Indeed. Nevertheless, I will be happier if they fix the bug that I reported (both to them and to the list). With a little luck, the bug will turn out to be in the driver, so they will have to fix it for all their products Smile

I have not experienced this bug - and I have installed the driver and software both on my MacBook with Mac OS X 10.5 and on a virtual Windows XP SP3 running under the Fusion virtualization software.
Back to top
View user's profile Send private message
ark



Joined: Mar 06, 2008
Posts: 676
Location: New Jersey
Audio files: 11
G2 patch files: 31

PostPosted: Thu Jan 29, 2009 11:59 am    Post subject: Re: Thank you, Clavia! Reply with quote  Mark this post and the followings unread

doctorno wrote:

I have not experienced this bug - and I have installed the driver and software both on my MacBook with Mac OS X 10.5 and on a virtual Windows XP SP3 running under the Fusion virtualization software.
And it happens on both of my machines, which are PCs running Windows XP SP3 directly.
Back to top
View user's profile Send private message Visit poster's website
dorremifasol



Joined: Sep 28, 2006
Posts: 780
Location: Barcelona, Spain
Audio files: 7
G2 patch files: 47

PostPosted: Thu Jan 29, 2009 12:10 pm    Post subject: Reply with quote  Mark this post and the followings unread

It happens to me also. Just open and close the editor many times.

Well it's not terrible, you can unplug and plug the usb cable again to fix it, but it's a bug worth of mention.

_________________
Cheers,
Albert
Back to top
View user's profile Send private message Visit poster's website
doctorno



Joined: Apr 10, 2007
Posts: 46
Location: Erkelenz, Germany
G2 patch files: 8

PostPosted: Thu Jan 29, 2009 12:50 pm    Post subject: Reply with quote  Mark this post and the followings unread

So it might be a problem with the Windows driver exclusively? Well, I have always said - you are running the wrong OS Wink .
Back to top
View user's profile Send private message
iPassenger



Joined: Jan 27, 2007
Posts: 1051
Location: Sheffield, UK
Audio files: 5
G2 patch files: 78

PostPosted: Fri Jan 30, 2009 2:46 am    Post subject: Reply with quote  Mark this post and the followings unread

Not experienced this bug but then i dont tend to open and close the editor many times (i usually leave it open for hours).. why are you all doing this?
_________________
iP (Ross)
- http://ipassenger.bandcamp.com
- http://soundcloud.com/ipassenger
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 7 [151 Posts]
View unread posts
View new posts in the last week
Goto page: 1, 2, 3, 4, 5, 6, 7 Next
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » Nord Modular G2 Discussion
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use