electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
Live streaming at radio.electro-music.com

  host / artist show at your time
  EdisonRex Edison's Electronic Review
  Twyndyllyngs Special Monday edition of Chez Mosc
Please visit the chat
 Forum index » Clavia Nord Modular » Nomad - NM1 Open Source Editor
unsupported patch format
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [7 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
brassica



Joined: Apr 01, 2010
Posts: 7
Location: London

PostPosted: Thu Oct 21, 2010 1:09 pm    Post subject: unsupported patch format Reply with quote  Mark this post and the followings unread

Hello all, please help me!

I love Nomad but unfortunately I can't open two thirds of my old patches, ones created years before Nomad.

Annoyingly the buggy old OS X editor opens and loads them all fine, just not Nomad. Only the patches which appear to be '3.0' open fine but not '2.10'.

What does 2.10 and 3.0 refer to? Is there a way to convert these 2.10 files perhaps?
I started out with my NM1 on OS X so I'm a bit unfamiliar with the old OS 9 days.

I use it so often though, I would love to get all patches opening in the wonderful Nomad.

Please help me!
Thanks so much,
Mike


net.sf.nmedit.jpatch.clavia.nordmodular.parser.ParseException: error@4:0: unsupported patch format:"Nord Modular patch 2.10"
at net.sf.nmedit.jpatch.clavia.nordmodular.parser.PParser.emiterror(PParser.java:160)
at net.sf.nmedit.jpatch.clavia.nordmodular.parser.PParser.emiterror(PParser.java:178)
at net.sf.nmedit.jpatch.clavia.nordmodular.parser.PParser.keyValuePair(PParser.java:474)
at net.sf.nmedit.jpatch.clavia.nordmodular.parser.PParser.header(PParser.java:424)
at net.sf.nmedit.jpatch.clavia.nordmodular.parser.PParser.section(PParser.java:339)
at net.sf.nmedit.jpatch.clavia.nordmodular.parser.PParser.sections(PParser.java:269)
at net.sf.nmedit.jpatch.clavia.nordmodular.parser.PParser.parse(PParser.java:206)
at net.sf.nmedit.jsynth.clavia.nordmodular.utils.NmUtils.parsePatch(NmUtils.java:453)
at net.sf.nmedit.jpatch.clavia.nordmodular.NMPatch.createPatchFromFile(NMPatch.java:521)
at net.sf.nmedit.nordmodular.NmFileService.openPatch(NmFileService.java:80)
at net.sf.nmedit.nordmodular.NmFileService.open(NmFileService.java:137)
at net.sf.nmedit.nomad.core.Nomad.openOrSelect(Nomad.java:946)
at net.sf.nmedit.nomad.core.swing.explorer.FileNode$3.run(FileNode.java:380)
at net.sf.nmedit.nmutils.swing.WorkIndicator$WrappedRunnable.run(WorkIndicator.java:60)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20536
Location: The Netherlands, Enschede
Audio files: 147
G2 patch files: 318

PostPosted: Thu Oct 21, 2010 1:33 pm    Post subject: Reply with quote  Mark this post and the followings unread

Just save then from the Clavia editor, that'll convert them from 2.10 to 3.x.
_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20536
Location: The Netherlands, Enschede
Audio files: 147
G2 patch files: 318

PostPosted: Thu Oct 21, 2010 1:35 pm    Post subject: Reply with quote  Mark this post and the followings unread

That is .. if you have a 3.x editor of course ....
_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
brassica



Joined: Apr 01, 2010
Posts: 7
Location: London

PostPosted: Thu Oct 21, 2010 4:42 pm    Post subject: Reply with quote  Mark this post and the followings unread

Blue Hell wrote:
Just save then from the Clavia editor, that'll convert them from 2.10 to 3.x.


Thanks, that is handy to know. But I have thousands of patches I was hoping to audition quickly in Nomad's internal directory browser.

Do you know of any ways to convert many .pch files? Do any batch convertors exist? I thought I'd found something online earlier but the links have expired.

Many thanks!
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20536
Location: The Netherlands, Enschede
Audio files: 147
G2 patch files: 318

PostPosted: Thu Oct 21, 2010 4:55 pm    Post subject: Reply with quote  Mark this post and the followings unread

brassica wrote:
Do any batch convertors exist?


Nope, but many publicized patches were converted already I think? - http://nm-archives.electro-music.com/010_NordModular/

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
brassica



Joined: Apr 01, 2010
Posts: 7
Location: London

PostPosted: Thu Oct 21, 2010 5:02 pm    Post subject: Reply with quote  Mark this post and the followings unread

Nope, but many publicized patches were converted already I think? - http://nm-archives.electro-music.com/010_NordModular/[/quote]

ooh, perfect. Thank you!
Back to top
View user's profile Send private message
Muzik 4 Machines



Joined: Jun 11, 2009
Posts: 8
Location: canada

PostPosted: Sun May 05, 2013 1:41 pm    Post subject: Reply with quote  Mark this post and the followings unread

the point of using nomad is that we can't use the nord editor on 10.7 and up, so there is no way to open and convert patches
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [7 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » Nomad - NM1 Open Source Editor
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use