electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
 Forum index » Clavia Nord Modular » Nomad - NM1 Open Source Editor
Nomad (NM open editor) pre release available for DL
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 3 of 3 [74 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Goto page: Previous 1, 2, 3
Author Message
dasz



Joined: Oct 16, 2004
Posts: 1640
Location: vancouver, canada
Audio files: 29
G2 patch files: 56

PostPosted: Wed Sep 20, 2006 8:09 am    Post subject: Reply with quote  Mark this post and the followings unread

I no longer have my NM1 (it's all G2 in the house). But I grabbed the editor just to see how it's going.

Wow! Amazing work!
/Dasz

_________________
http://www.clavia.se/misc/users/daszgarncarz.htm
http://haagenlive.blogspot.com/
Back to top
View user's profile Send private message Visit poster's website
Oval



Joined: Feb 22, 2006
Posts: 5
Location: Russia

PostPosted: Sat Sep 23, 2006 9:47 am    Post subject: Re: Nomad working on Micro Modular
Subject description: Nomad working on Micro Modular
Reply with quote  Mark this post and the followings unread

[quote="chresan"]
sonicacid wrote:
Hi,
Beside that next version of Java (1.6) should bring advantages in rendering time. And in the future it will be possible to enable the opengl- or directDraw/direct3D pipelines for java applications, this will bring further advantages.
Christian

Did you ever try
java -Dsun.java2d.opengl=true
or
System.setProperty("sun.java2d.opengl", "true");

in 1.5 ?
Back to top
View user's profile Send private message
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Sat Sep 23, 2006 10:36 pm    Post subject: Re: Nomad working on Micro Modular
Subject description: Nomad working on Micro Modular
Reply with quote  Mark this post and the followings unread

Oval wrote:

Did you ever try
java -Dsun.java2d.opengl=true
or System.setProperty("sun.java2d.opengl", "true");
in 1.5 ?

Yes, I did. But I decided not to tell about it here. Using the opengl rendering might lead to vm crashes in 1.5. When the crashes are gone in 1.6 or later I will recommend this feature, but not earlier.

Christian

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
eposk



Joined: Apr 29, 2005
Posts: 155
Location: Portland, OR
G2 patch files: 1

PostPosted: Tue Oct 03, 2006 8:56 am    Post subject: Reply with quote  Mark this post and the followings unread

to do list for the next version of Nomad-

-Randomizer


Very Happy Very Happy Very Happy

Im just looking for one button that randomizes all the knobs, similar to the access virus random button, or something similar. This would be an excellent addition to a classic synth.

cheers.
Back to top
View user's profile Send private message Visit poster's website
VenaViola



Joined: Oct 29, 2006
Posts: 7
Location: Benevento Italia

PostPosted: Sun Oct 29, 2006 6:39 am    Post subject: Nomad on the tiger 4.6 Reply with quote  Mark this post and the followings unread

I have nord modular editor java.....oh the my ibook g4 with osx 10.4.6. It isn't run Sad
Back to top
View user's profile Send private message
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Sun Oct 29, 2006 7:42 am    Post subject: Re: Nomad on the tiger 4.6 Reply with quote  Mark this post and the followings unread

VenaViola wrote:
I have nord modular editor java.....oh the my ibook g4 with osx 10.4.6. It isn't run Sad


Have you installed Plumstone ? (available here http://www.mandolane.co.uk/ )

In the nomad directory there is a log file 'nomad.log', can you post it here - it might contain information about the problem


Christian

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
VenaViola



Joined: Oct 29, 2006
Posts: 7
Location: Benevento Italia

PostPosted: Sun Oct 29, 2006 8:19 am    Post subject: Reply with quote  Mark this post and the followings unread

this is error :
ibook-g4-di-venaviola:~/documents/nomad VenaViola$ java -jar nomad.jarException in thread "main" java.lang.UnsupportedClassVersionError: net/sf/nmedit/nomad/core/nomad/Nomad (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

i have install plumestone but isn't run nomad Sad i have jse 5.0
Back to top
View user's profile Send private message
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Sun Oct 29, 2006 11:04 am    Post subject: Reply with quote  Mark this post and the followings unread

VenaViola wrote:
... i have install plumestone but isn't run nomad Sad i have jse 5.0

I have done some research on this error. The problem is probably caused because you are running an older java interpreter. Please check the java version with the command
Code:
java -version
. If it is an older version than java 5.0 (1.5) you have to make Java 5 the default java VM on your computer. Please let me know when you still need help or if this solution fixed the problem.

Christian

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
VenaViola



Joined: Oct 29, 2006
Posts: 7
Location: Benevento Italia

PostPosted: Sun Oct 29, 2006 12:31 pm    Post subject: Reply with quote  Mark this post and the followings unread

the version of my java pakage is 1.4.2. I download this pakage from apple site
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20623
Location: The Netherlands, Enschede
Audio files: 150
G2 patch files: 318

PostPosted: Sun Oct 29, 2006 2:09 pm    Post subject: Reply with quote  Mark this post and the followings unread

VenaViola wrote:
the version of my java pakage is 1.4.2. I download this pakage from apple site


Sounds like the same problems that Sven (3phase) had initially - see first page of this thread for more info.

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
VenaViola



Joined: Oct 29, 2006
Posts: 7
Location: Benevento Italia

PostPosted: Mon Oct 30, 2006 10:00 am    Post subject: Reply with quote  Mark this post and the followings unread

The nomad interface very very cool!!! i have install the plum stone v 1.3 and have setting my midi device (motu828mk2) but the nomad sw not load or transmit the patch Sad
Back to top
View user's profile Send private message
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Mon Oct 30, 2006 11:59 am    Post subject: Reply with quote  Mark this post and the followings unread

VenaViola wrote:
The nomad interface very very cool!!! i have install the plum stone v 1.3 and have setting my midi device (motu828mk2) but the nomad sw not load or transmit the patch Sad

There are several cases you could check:
1. Look again in the file 'nomad.log' if there is something mentioned about an exception. If so then post the log file here.
2. There is a known bug in the midi configuration dialog. When your midi interface has more than one in/output ports and when they have all the same name in the connection dialog then you should try the first port of the midi interface (Port A or Port 1).

Note that you have to use the Menu Synth->Download to Slot XY to send the patch to the synth.

Christian

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
bankbot



Joined: Nov 02, 2006
Posts: 2
Location: olympia

PostPosted: Thu Nov 02, 2006 4:14 pm    Post subject: Nomad on itelmac Reply with quote  Mark this post and the followings unread

Hey everyone, I was wondering if anyone had tried using nomad on an Intelmac such as the macbook and if they had had any success?
Back to top
View user's profile Send private message
Oval



Joined: Feb 22, 2006
Posts: 5
Location: Russia

PostPosted: Fri Nov 03, 2006 4:54 am    Post subject: Re: Nomad working on Micro Modular
Subject description: Nomad working on Micro Modular
Reply with quote  Mark this post and the followings unread

chresan wrote:
Oval wrote:

Did you ever try
java -Dsun.java2d.opengl=true
or System.setProperty("sun.java2d.opengl", "true");
in 1.5 ?

Yes, I did. But I decided not to tell about it here. Using the opengl rendering might lead to vm crashes in 1.5. When the crashes are gone in 1.6 or later I will recommend this feature, but not earlier.

Christian

Hi Christian!
May be you are interesting in this - http://forum.java.sun.com/thread.jspa?threadID=782276&tstart=0
And may be you will add playing test midifiles feature in your program to check out edited patch.
Back to top
View user's profile Send private message
VenaViola



Joined: Oct 29, 2006
Posts: 7
Location: Benevento Italia

PostPosted: Fri Nov 03, 2006 5:08 am    Post subject: Reply with quote  Mark this post and the followings unread

exscuse me exsiste jre 5.0 (1.5) for os x 10.3.9?
Back to top
View user's profile Send private message
bankbot



Joined: Nov 02, 2006
Posts: 2
Location: olympia

PostPosted: Fri Nov 03, 2006 12:30 pm    Post subject: Intelmac Nomad Problems Reply with quote  Mark this post and the followings unread

Hey everyone, I tried the nomad on an intelmac and it fired up but for some reason it wouldnt recognize the midi in/out device that was installed and plugged into the computer. Has anyone else had problems with the nomad not recognizing their audio/midi card?
Back to top
View user's profile Send private message
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Sun Nov 05, 2006 8:54 am    Post subject: Reply with quote  Mark this post and the followings unread

VenaViola wrote:
exscuse me exsiste jre 5.0 (1.5) for os x 10.3.9?

Hi, I am sorry but I cannot answer your question. I have searched a while for an answer, but it seems that for JSE 5 you need os x 10.4.2 or later. But you should try and ask your question in a apple forum ( theres is one on apple.com )

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
j



Joined: Dec 06, 2006
Posts: 26
Location: us

PostPosted: Fri Dec 22, 2006 5:58 pm    Post subject: Reply with quote  Mark this post and the followings unread

Wow.The possibilities of performances and a random patch button or mutator made me decide there is no way i will sell my nm1 keyboard!
Back to top
View user's profile Send private message
mynameisstuart



Joined: Dec 24, 2006
Posts: 2
Location: uk

PostPosted: Sun Dec 24, 2006 3:55 pm    Post subject: deleting in the editor Reply with quote  Mark this post and the followings unread

hi all, this is a great program!!! just one thing i can't delete things in the editor like osc, filter etc. i've tried everything hilight it 'apple delete' 'control delete' everything. if someone could tell me how to delete i would to so grateful.
Back to top
View user's profile Send private message
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Thu Dec 28, 2006 1:21 pm    Post subject: Re: deleting in the editor Reply with quote  Mark this post and the followings unread

mynameisstuart wrote:
hi all, this is a great program!!! just one thing i can't delete things in the editor like osc, filter etc. i've tried everything hilight it 'apple delete' 'control delete' everything. if someone could tell me how to delete i would to so grateful.


The pre release does not support keyboard shortcuts, you have to wait for the next release.

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
mynameisstuart



Joined: Dec 24, 2006
Posts: 2
Location: uk

PostPosted: Fri Jan 19, 2007 12:47 pm    Post subject: setting up with a midisport 2x2 Reply with quote  Mark this post and the followings unread

hi, i'm having a few problem getting started with this software. i can't get my midi interface to work and sync up. PLEASE PLEASE HELP ME

cheers stuart
Back to top
View user's profile Send private message
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Fri Jan 19, 2007 1:28 pm    Post subject: Re: setting up with a midisport 2x2 Reply with quote  Mark this post and the followings unread

mynameisstuart wrote:
hi, i'm having a few problem getting started with this software. i can't get my midi interface to work and sync up. PLEASE PLEASE HELP ME

cheers stuart


Hi Stuart,

which midi interface do you have ? And does the midi device dialog contain duplicate entries ? If the log file nomad/nomad.log contains errors can you post the file here ?

Christian

Edit: Ah, I missed the changed subject. I have also the midisport 2x2 and it should work. But depending on your os you can only use Midi In A and Midi Out A.

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
Gothboy



Joined: Feb 21, 2006
Posts: 361
Location: New England States
Audio files: 2

PostPosted: Sat Feb 03, 2007 7:05 am    Post subject: Reply with quote  Mark this post and the followings unread

Can the Nomad editor work with Panther 10.3.9? I'm not running tiger but I'd like to check out the editor. I also wanted to know if Java Runtime 5 is compatible with Panther. I know this thread is a little old but my dedicated Opcode 3 midi interface died a mysterious death Rolling Eyes so I need to run the editor from my main G4 machine. I have the Clavia beta but I'd heard about the Nomad project. Thanks.
_________________
Apple Mac Pro 2.66 GHz. Intel Xeon Quad core
9GB RAM
Snow Leopard 10.6.8/Pro Tools 8.0.5 Digi 002R
M-Audio Radium 61/Novation Remote Zero SL/AlphaTrack controllers
Automap 3.7
Fxspansion VST-RTAS adapter
Networked to>
G4 Dual 1.4 processor 1.25GB RAM
Pro Tools 7.3.1cs8/Tiger 10.4.11

"We are the music makers and we are the dreamers of dreams"

Dymaxion Vehicle Music at www.dymaxionvehicle.com/
Back to top
View user's profile Send private message Visit poster's website
chresan



Joined: Jul 11, 2006
Posts: 150
Location: Karlsruhe, Germany

PostPosted: Sat Feb 03, 2007 8:59 am    Post subject: Reply with quote  Mark this post and the followings unread

Gothboy,

as far as I know there is no official support for Java 5 in os x 10.3.9 (but in 10.4). But take a look at the links:
http://bact.blogspot.com/2005/09/java-5-on-mac-os-x-103.html
and
http://lists.apple.com/archives/java-dev/2005/Apr/msg00669.html . There is a script attached which installs Java 5 on 10.3.x. Perhaps you have luck and it works for you. But you should only use it for java applications that require Java 5, for the others keep your current java installation.

Perhaps you can post some feedback here, whether this solution works for you or not.

Sincerely,
Christian

_________________
----------------------
http://nmedit.sf.net
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 3 of 3 [74 Posts]
View unread posts
View new posts in the last week
Goto page: Previous 1, 2, 3
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » Nomad - NM1 Open Source Editor
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use