electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
 Forum index » Clavia Nord Modular » Bugs
Bank select + program change + control change 121 = crash.
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [4 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
extone



Joined: May 29, 2006
Posts: 4
Location: Australia

PostPosted: Fri Oct 19, 2007 2:22 am    Post subject: Bank select + program change + control change 121 = crash.
Subject description: Anyone willing to confirm my crash?
Reply with quote  Mark this post and the followings unread

Hello everyone, sorry to say my first post on these forums is a bug.

I have noticed my G2 engine crashing when I send a bank select, followed by program change followed by reset all controllers message.

This is the normal MIDI messages I send to the G2 to control it from my sequencer:

CC BANK LSB 32
PC PROGRAM CHANGE
(Top down order)

This has always worked fine.

However if I add CC 121 (reset all controllers) to this list so that when I change the bank/preset in my sequencer it outputs:

CC BANK LSB 32
PC PROGRAM CHANGE
CC RESET ALL CONTROLLERS 121

My G2's MIDI light goes and and does not turn off and the editor outputs a message saying it has lost USB contact. I have to turn off/on before it works again.

I have replicated this crash using Cubase SX3 and Zynewave Podium (the only two sequencers I have at hand) occasionally it does not crash but the second or third time I try it crashes. It always eventually crashes.

The problem definitely seems to be related to MIDI CC 121, however when using MIDI-OX if I send a single message 121 directly to the G2 it does not crash no matter how many I throw at it.

I can only replicate this crash using sequencer software since it only seems to happen when these three MIDI messages are sent together.

Is anyone willing to try and replicate this crash to see if it is an issue with my own G2 or a real bug?

In Cubase it is fairly easy to simply add the CC121 onto the end of the normal bank select/program change pair that is normally used for hardware preset selection.

(The crash does not happen when I turn off receiving control change messages on my G2 which confirms that this definitely has something to do with CC121)
Back to top
View user's profile Send private message Visit poster's website
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20270
Location: The Netherlands, Enschede
Audio files: 143
G2 patch files: 318

PostPosted: Fri Oct 19, 2007 3:34 am    Post subject: Reply with quote  Mark this post and the followings unread

welcome extone,

I'll try to check this out later today when I'm at home again.

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20270
Location: The Netherlands, Enschede
Audio files: 143
G2 patch files: 318

PostPosted: Fri Oct 19, 2007 10:51 am    Post subject: Reply with quote  Mark this post and the followings unread

On one of my engines I made a patch that sends

bank change CC 32 - to bank 1 (value 0)
program change (to a random program (performance) that exists)
CC 121 (with values of 0, 1 and 127)

to the other engine, all on CH 16, which I use as the global channel on that 2nd engine).

This doesn't result in a crashing engine here.

I might be doing something different of course Very Happy

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
extone



Joined: May 29, 2006
Posts: 4
Location: Australia

PostPosted: Fri Oct 19, 2007 2:50 pm    Post subject: Reply with quote  Mark this post and the followings unread

Interesting, thanks for that. I am doing more tests. I have not been using performances with global channel.

I just tried using the same midi commands on a performance with global channel on and it loaded everything fine! I turn global channel back off again and try and load a patch and..as expected..crash!

So it only seems to happen with global channel set to off and you are trying to load patches along with a CC121. I must have crashed my G2 about 10 times testing all this.. i hope it's alright...
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [4 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » Bugs
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
emSynth

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use