electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
Live streaming at radio.electro-music.com

  host / artist show at your time
  Rob Adventures in Sound
Please visit the chat
 Forum index » DIY Hardware and Software » YuSynth
ADSR v.2 GATE PROBLEM
Post new topic   Reply to topic Moderators: Scott Stites
Page 1 of 2 [31 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Goto page: 1, 2 Next
Author Message
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Wed May 09, 2012 7:14 pm    Post subject: ADSR v.2 GATE PROBLEM Reply with quote  Mark this post and the followings unread

hi guys
i built the 2° version of this nice adsr, with all the optional available:
switch for fast/slow rate,
led, inverted output and of course the push button to fire manually the gate
i tried directly to have some fun with this last one, to see if everything was fine and from my point of view it works very well.
but then, when i tried the gate in with my keyboard, all my entusiasm was gon.e
the gate in is not working, i quickly checked the wiring, soldering, components value and it looks ok.
then i tried to keep the push button pressed and finally the keyboard is doing the job!?! Shocked
what i did wrong?
can somebody help me to find the problem?
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Thu May 10, 2012 4:27 am    Post subject: Reply with quote  Mark this post and the followings unread

Are you sure you use a PUSH-TO-MAKE button ? Otherwise check your wiring.
By the way what GATE signal is providing your keyboard : 0V OFF , 5V or more PRESSED ?

_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Thu May 10, 2012 8:42 am    Post subject: Reply with quote  Mark this post and the followings unread

well, actually, as push button i'm using this:
http://www.banzaimusic.com/PIC-PB11-BLK.html
and as gate i'm using the novation bass station that can give me many kind of cv/gate conversion, but no one is working; as i already said the gate works only if i keep the push button pressed.
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Thu May 10, 2012 9:38 am    Post subject: Reply with quote  Mark this post and the followings unread

I wanted to check the available outputs of the Novation Bass Station but could not find a GATE output in the owner manual. May be its a different model you have. Can you measure the GATE signal that comes out of your keyboard ?
_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Thu May 10, 2012 10:33 am    Post subject: Reply with quote  Mark this post and the followings unread

I remember that when I added the new ADSR on my site , the PDF file of the PCB had a missing track (I think it was the track between the emitters of Q1 & Q2), but this has been corrected long ago now but if you collected the PCB file prior to the fix, this track may be missing on your PCB and would explain your problem. Please post a photo of your PCB.
_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Thu May 10, 2012 2:30 pm    Post subject: Reply with quote  Mark this post and the followings unread

i knew about that issue with the emitters of Q1 & Q2 but i downloaded the layout in july 2011 and yesterday, just to be sure i downloaded it again and checked with photoshop if there are difference with the one i've etched and is ok.
the novation bass station gate is pretty hot, around 13v Shocked
i thought there was something wrong with my multimeter but then when i checked the trigger out of my MS20 i got around 5v so the multimeter is also ok
tried again to use the keyboard of my Ms20 to gate the adsr....nothing
right now i'm thinking about swapping the push button and gate in or maybe to omit the push button till i don't find a solution

on board i included pads for the pots but i dont think this could be a problem


Photo on 2012-05-10 at 23.20.jpg
 Description:
 Filesize:  92.13 KB
 Viewed:  126 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

Photo on 2012-05-10 at 23.20.jpg


Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Thu May 10, 2012 2:31 pm    Post subject: Reply with quote  Mark this post and the followings unread

components


Photo on 2012-05-10 at 23.21.jpg
 Description:
 Filesize:  101.65 KB
 Viewed:  120 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

Photo on 2012-05-10 at 23.21.jpg



Photo on 2012-05-10 at 23.21.jpg
 Description:
 Filesize:  101.65 KB
 Viewed:  118 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

Photo on 2012-05-10 at 23.21.jpg


Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Thu May 10, 2012 2:40 pm    Post subject: Reply with quote  Mark this post and the followings unread

The photos are too low resolution to be really helpful.
13V for the GATE is OK, the circuit is designed to accept even more.

_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Thu May 10, 2012 3:14 pm    Post subject: Reply with quote  Mark this post and the followings unread

luckily i found the battery for my camera Very Happy


IMG_9688.JPG
 Description:
 Filesize:  1.93 MB
 Viewed:  129 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

IMG_9688.JPG


Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Thu May 10, 2012 3:16 pm    Post subject: Reply with quote  Mark this post and the followings unread

copper side 1


IMG_9689.JPG
 Description:
 Filesize:  1.9 MB
 Viewed:  124 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

IMG_9689.JPG


Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Thu May 10, 2012 3:21 pm    Post subject: Reply with quote  Mark this post and the followings unread

2


IMG_9690.JPG
 Description:
 Filesize:  1.84 MB
 Viewed:  119 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

IMG_9690.JPG


Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Fri May 11, 2012 8:08 am    Post subject: Reply with quote  Mark this post and the followings unread

I can't see anything wrong with the PC and components (did you use BC547C ?) .

Can you measure the voltage on the base of Q1 :

    Without the keyboard connected : push button OFF then push button ON
    Then with keyboard connected and push button OFF : pressing a key, then releasing it.
    Repeating the previous but with the push button ON


Can you also repeat all these mesurements on the collector of Q2 ?

_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Fri May 11, 2012 8:50 am    Post subject: Reply with quote  Mark this post and the followings unread

i' ve used bc550 that are just slightly different
in a while i'll start with measurement and then report
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Fri May 11, 2012 9:26 am    Post subject: Reply with quote  Mark this post and the followings unread

BC550 should be OK
_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
Benjamin AM



Joined: Nov 04, 2010
Posts: 57
Location: Boise

PostPosted: Mon May 14, 2012 5:04 pm    Post subject: Reply with quote  Mark this post and the followings unread

tokyomatik,
I like how you've used the pots to panel mount. I'm going to have to give that a a try myself. Thanks for the idea!
Back to top
View user's profile Send private message
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Tue May 15, 2012 7:34 pm    Post subject: Reply with quote  Mark this post and the followings unread

i finally measured the base of Q1 & Q2
and here is what i got:
Q1 :
-no keyboard and no push button 675mA
-keyboard 674mA
-push button 619mA
-push button + keyboard 00mA

Q2
-no keyboard and no push button 20.6mA
-keyboard 20.7mA
-push button 103.6
-push button + keyboard 711mA

mmhhh...i'm a total beginner but i would say something is wrong with Q2...?
Confused any tips?
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Tue May 15, 2012 7:44 pm    Post subject: Reply with quote  Mark this post and the followings unread

Ops!!
in the measurement i made before the keyboard was connected
so i checked again without any input at the Gate
and i got this:
Q1
- no push button 675mA
- push button 118mA

Q2
- no push button 20.6mA
- push button 712mA

ok now I'm even more confused.... Rolling Eyes
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Wed May 16, 2012 1:51 am    Post subject: Reply with quote  Mark this post and the followings unread

Do you mean mV instead of mA ???
Where you using the mV range (OK) or the mA range (Wrong) ?

You must measure voltages therefore use the V or mV range of your DVM.
Measurements on the base pin of Q1 (red wire and black wire to 0V) and measurements on the collector pin of Q2.

_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Wed May 16, 2012 10:15 am    Post subject: Reply with quote  Mark this post and the followings unread

ehm ...i was not completely awake Embarassed but yes i meant V
so new measurement for collector of Q2:
no push button no keyboard connected 11.92V
push button 00V
keyboard 11.92v
keyboard and push button 0.02v

and just to be sure again measurement at base Q1:
no push button no keyboard connected 0.675 / 0.677v
push button 0.031v
keyboard connected 0.678v
keyboard and push button 0.00v

Rolling Eyes
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Wed May 16, 2012 2:52 pm    Post subject: Reply with quote  Mark this post and the followings unread

OK then your measurements are showing a very strange behavior, acting exactly opposite to what it should.
Normally, I would expect 0V on the base of Q1 when nothing is connected and the push is OFF, then that something like 0.6 to 0.7V when a GATE ON signal is applied or he pushbutton is pushed ON.
The same stands for Q2, I would expect 0V when nothing is connected and the push is OFF, then something between 11V and 15V when a GATE ON signal is applied or he pushbutton is pushed ON.

I suggest that you check thoroughly the tracks for a shortcut around Q1.

Also can you check with a continuity tester that your push button is a real PUSH TO MAKE and not a PUSH TO BREAK ? A test would be to disconnect the push button and measuring again the voltage on the base of Q1 when no keyboard is connected.

_________________
Yves

Last edited by yusynth on Thu May 17, 2012 12:00 am; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Wed May 16, 2012 11:52 pm    Post subject: ADSR v.2 GATE PROBLEM (FIXED) Reply with quote  Mark this post and the followings unread

You can also check that the wire to the gate input jack are not crossed.
_________________
Yves

Last edited by yusynth on Sat Jun 09, 2012 11:30 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Wed May 23, 2012 2:06 pm    Post subject: Reply with quote  Mark this post and the followings unread

hey finally i solved....actually it was the push button....ufff it was so easy....
damn i ordered more of those buttons and now what should i do with those little bastards Confused
anyway the adsr is just great, i'm gonna build for sure a dual version soon or maybe a quad, never enough with envelope generators Very Happy
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Fri May 25, 2012 12:22 am    Post subject: Reply with quote  Mark this post and the followings unread

tokyomatik wrote:
hey finally i solved....actually it was the push button....ufff it was so easy....
damn i ordered more of those buttons and now what should i do with those little bastards Confused
anyway the adsr is just great, i'm gonna build for sure a dual version soon or maybe a quad, never enough with envelope generators Very Happy


Hey it was my first suspect if you remember Wink

Great.

_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
tokyomatik



Joined: Jan 20, 2011
Posts: 122
Location: berlin
Audio files: 6

PostPosted: Fri May 25, 2012 2:07 am    Post subject: Reply with quote  Mark this post and the followings unread

yes master, i know, is a long way before to get finally a lazersword.....Wink
Back to top
View user's profile Send private message Visit poster's website
yusynth



Joined: Nov 24, 2005
Posts: 1214
Location: France

PostPosted: Sun Jun 10, 2012 12:19 am    Post subject: Reply with quote  Mark this post and the followings unread

Embarassed Embarassed Embarassed Embarassed I just noted a big typo in the schematic diagram and component layout diagram. I stupidly inverted the polarity of D5 and of the LED. I have just corrected the diagrams on my site. Embarassed Embarassed Embarassed

Therefore, invert D5 and the LED and you will obtain a normal behaviour for the LED. You may adjust the value of R22 (1K to 1.8K) to set the maximum brillance for the LED.

_________________
Yves
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Moderators: Scott Stites
Page 1 of 2 [31 Posts]
View unread posts
View new posts in the last week
Goto page: 1, 2 Next
Mark the topic unread :: View previous topic :: View next topic
 Forum index » DIY Hardware and Software » YuSynth
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
AmbiphonicDSP

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use