electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
 Forum index » DIY Hardware and Software
Discrete Transistor 2040 SVVCF
Post new topic   Reply to topic Moderators: jksuperstar, Scott Stites, Uncle Krunkus
Page 3 of 3 [59 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Goto page: Previous 1, 2, 3
Author Message
gabbagabi



Joined: Nov 29, 2008
Posts: 539
Location: Berlin by n8
Audio files: 23

PostPosted: Fri Oct 27, 2017 1:37 am    Post subject: Reply with quote  Mark this post and the followings unread

i would be interested in the results too - if they are good, may i go and make a pcb for it

cheers
Back to top
View user's profile Send private message
maltasynth65



Joined: Jul 20, 2016
Posts: 9
Location: MALTA

PostPosted: Fri Oct 27, 2017 4:04 pm    Post subject: latest mods Reply with quote  Mark this post and the followings unread

I have done the mods suggested and I have to report that the filter is now worse then before!!! Half the frequency pot is dead, the resonance pot has reversed its function and resonance behaviour is erratic. Bearing in mind that others have reported favourably, I am accepting the fact that I may have made similar major mistakes on the two different perfboard layouts and will for now pause this project and move on until I would have the time to rethink things again...
Back to top
View user's profile Send private message
gabbagabi



Joined: Nov 29, 2008
Posts: 539
Location: Berlin by n8
Audio files: 23

PostPosted: Tue Oct 31, 2017 10:26 am    Post subject: Reply with quote  Mark this post and the followings unread

Even multisim is reluctant to show a "usable" result
Back to top
View user's profile Send private message
maltasynth65



Joined: Jul 20, 2016
Posts: 9
Location: MALTA

PostPosted: Wed Nov 01, 2017 12:21 am    Post subject:
Subject description: ACTUAL RESULTS
Reply with quote  Mark this post and the followings unread

thing is that the circuit actually works. However it needs to have those two resistors in circuit, cos like I stated earlier, without them, it goes nuts. I made them switchable, kinda "MODE A/B" Very Happy and can get some mean madness out if it. As it happens, this is my very first filter build so I did not have anything to compare it to, but now that I have built YuSynth's Parker-Steiner, I can say that this DOES work. It would be nice if someone else who have actually built the SVVCF would kindly comment on the results achieved.
Back to top
View user's profile Send private message
etheory



Joined: Feb 20, 2013
Posts: 13
Location: Sydney

PostPosted: Mon Nov 06, 2017 6:29 am    Post subject: Reply with quote  Mark this post and the followings unread

I'm really sorry guys, I didn't realize how many issues the original schematic really had....

Here's the fixes + a simulation to show it really does work:

The main changes are removing the 10uF caps inside the feedback loop, which shouldn't be there, along with the biasing of the +5V which now isn't needed anywhere.

The other change is the 10K resistor in the top of the main feedback loop to 100K. And basically all resistors aside from the ones just before the gm cell transistors (the 10K and 220R dividers) should be 100K.

Now it'll work.

The main reason it was oscillating for you was the 10uF caps and the 10K feedback resistor.

The LTSpice sim works perfectly with these changes.


SVF_Fixed_etheory_2.jpg
 Description:
 Filesize:  848.14 KB
 Viewed:  303 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

SVF_Fixed_etheory_2.jpg



SVF_Fixed_etheory_2_sim.jpg
 Description:
 Filesize:  699.37 KB
 Viewed:  243 Time(s)
This image has been reduced to fit the page. Click on it to enlarge.

SVF_Fixed_etheory_2_sim.jpg


Back to top
View user's profile Send private message Visit poster's website
maltasynth65



Joined: Jul 20, 2016
Posts: 9
Location: MALTA

PostPosted: Mon Nov 06, 2017 2:11 pm    Post subject:
Subject description: revised circuit
Reply with quote  Mark this post and the followings unread

wow! thanks, mate.....no cause for apologies..it is all part of the loop....and I for one appreciate your efforts and your listening to us, that's how things get done!!! I'll take on board your new findings and see how it goes.....again, thanks.
Back to top
View user's profile Send private message
etheory



Joined: Feb 20, 2013
Posts: 13
Location: Sydney

PostPosted: Mon Nov 06, 2017 6:27 pm    Post subject:
Subject description: revised circuit
Reply with quote  Mark this post and the followings unread

maltasynth65 wrote:
wow! thanks, mate.....no cause for apologies..it is all part of the loop....and I for one appreciate your efforts and your listening to us, that's how things get done!!! I'll take on board your new findings and see how it goes.....again, thanks.


You are more than welcome.
I don't stop until something is working properly, we'll get there! Cool
Back to top
View user's profile Send private message Visit poster's website
gabbagabi



Joined: Nov 29, 2008
Posts: 539
Location: Berlin by n8
Audio files: 23

PostPosted: Wed Nov 08, 2017 10:41 am    Post subject: Reply with quote  Mark this post and the followings unread

thanks.
now it somehow works in my simulation programm.
But i would still put a questionmark on R7. With 100k it will not work right. 10k is doing better.

so far, keep well
Back to top
View user's profile Send private message
etheory



Joined: Feb 20, 2013
Posts: 13
Location: Sydney

PostPosted: Wed Nov 08, 2017 4:48 pm    Post subject: Reply with quote  Mark this post and the followings unread

g.gabba wrote:
thanks.
now it somehow works in my simulation programm.
But i would still put a questionmark on R7. With 100k it will not work right. 10k is doing better.

so far, keep well


In order to be a true state-variable filter, and fulfill the s-domain math equation, the feedback resistors need to all be the same value, whatever that is (aside from the bandpass filter feedback, which should have half that value, to keep the feedback values 1, 2, 1 for high pass, bandpass, lowpass, which is the true SVF configuration).

If you make them all 10K, they can be, with a difference in centre frequency, just don't mix 100K and 10K.

How does that affect your simulation? I'm guessing you've accidentally mixed some values. The 10K/220R divider before the gm cells should stay the same.

Make sure you are aware that the resonance control works "backwards", i.e. at lowest output, the resonance is the highest. That might effect the way you view your sim also.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Moderators: jksuperstar, Scott Stites, Uncle Krunkus
Page 3 of 3 [59 Posts]
View unread posts
View new posts in the last week
Goto page: Previous 1, 2, 3
Mark the topic unread :: View previous topic :: View next topic
 Forum index » DIY Hardware and Software
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use