electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
Live streaming at radio.electro-music.com

  host / artist show at your time
  mosc Back on the air tonight - Twyndyllyngs
Please visit the chat
 Forum index » DIY Hardware and Software » ChucK programming language
Chuck Lisa issue on Linux -- no sound
Post new topic   Reply to topic Moderators: Kassen
Page 1 of 1 [2 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
briansorahan



Joined: Feb 17, 2013
Posts: 3
Location: Austin, TX

PostPosted: Sun Feb 17, 2013 4:23 pm    Post subject: Chuck Lisa issue on Linux -- no sound Reply with quote  Mark this post and the followings unread

Hi all,
Thought I would check on the forum before I report a bug.
I'm testing LiSa on Ubuntu 12.04 32bit with linux-jack.
In the following code, if I toggle the commenting of lines 5 and 6, I can make this patch create sound/not-create sound.

Code:
     1   // Audio Patch
     2   SinOsc osc;
     3   LiSa saveme;
     4   Gain channelGain;
     5   // osc => saveme => channelGain => dac;
     6   osc => channelGain => dac;
     7   
     8   // Control parameters
     9   440 => osc.freq;
    10   0.5 => osc.gain;
    11   1.0 => channelGain.gain;
    12   
    13   // Start recording with LiSa
    14   5::second => saveme.duration;
    15   
    16   1 => saveme.record;
    17   2::second => now;
    18   0 => saveme.record;
    19   1 => saveme.play;
    20   2::second => now;
    21   0 => saveme.play;


Am I doing something stupid? Is this a bug?

Thanks!
Brian
Back to top
View user's profile Send private message
briansorahan



Joined: Feb 17, 2013
Posts: 3
Location: Austin, TX

PostPosted: Fri Mar 01, 2013 10:56 am    Post subject: Reply with quote  Mark this post and the followings unread

An update: I just tried this with a linux-alsa build and have the same issue
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Moderators: Kassen
Page 1 of 1 [2 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » DIY Hardware and Software » ChucK programming language
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use