electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
Live streaming at radio.electro-music.com

  host / artist show at your time
  EdisonRex Edison's Electronic Review
  Twyndyllyngs Special Monday edition of Chez Mosc
Please visit the chat
 Forum index » Clavia Nord Modular » Nord Modular G2 Discussion
Issue with Event Sequencer START position and midi clock Bug
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [10 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
ssgrfk



Joined: Oct 21, 2011
Posts: 12
Location: Berlin

PostPosted: Fri Oct 21, 2011 8:14 am    Post subject:  Issue with Event Sequencer START position and midi clock Bug
Subject description: Issue with Event Sequencer START position and midi clock Bug
Reply with quote  Mark this post and the followings unread

Hey.
Im using the G2 with Midi clock slaved to Ableton Live.
Im recording the Audio output back into Live.

im using event sequencers to trigger drum oscillators to make drum machine like sounds. like Clock Generator -> Clock Divider -> Event Sequencer -> ETC

This is all working as expected but recently i noticed something where, on a Patch that takes the tempo from a Clock Generator at 1/96, the recored output in Ableton would be a few Milliseconds off.. the audio is in sync, just offset so that its either slightly early, on time or late.

this was driving me mad for a while as i thought it was an ableton midi thing then i played around with other patches on the Nord and found that it was only happening in my Patch

I then changed the patch so that it took the Midi Clock from the 1/16 output in the Clock Generator and then divided it differently to tigger the patch..

When i recorded the audio, it was always in sync and locked in at the correct startpoint..

So it appears as though when on 1/96 that the patch start time is slightly variable and causing me some problems..

has anyone else ever noticed this before or have any suggestions what might be causing this?
thanks!
Back to top
View user's profile Send private message Visit poster's website
Antimon



Joined: Jan 18, 2005
Posts: 3702
Location: Sweden
Audio files: 270
G2 patch files: 96

PostPosted: Fri Oct 21, 2011 11:27 am    Post subject: Reply with quote  Mark this post and the followings unread

welcome ssgrfk

Interesting observation!

I generally don't slave anything off software, especially so with the G2 - it's very picky about stable MIDI clocks.

But also I often experience that Live behaves weirdly but consistently when it comes to recording audio, even though it makes no sense.

Case in point: when I play on my OP-1 and record, Live almost always messed up the timing to the point that the recorded clip goes totally out of sync after one or two bars. I need to open the clip and manually remove the markers so I can correct things. When I record similarly using other instruments I don't have the same problem.

I think I've found that Live behaves differently (better) if I change the default Warp method (used to be "beats", now it's "tones").

Since the G2 MIDI clock problem usually manifests by missing clock ticks and going out of sync (which doesn't seem to happen to you), I would guess that messing around with Live's default Warp settings might help (it's in preferences, the "Record Warp Launch" tab, called "Default Warp Mode").
You might want to try slaving Live off the G2 too - you never know...

I'd be interested to hear more about what you find out about this!

/Stefan

_________________
Antimon's Window
@soundcloud @Flattr home - you can't explain music
Back to top
View user's profile Send private message Visit poster's website
ssgrfk



Joined: Oct 21, 2011
Posts: 12
Location: Berlin

PostPosted: Fri Oct 21, 2011 11:36 am    Post subject: Reply with quote  Mark this post and the followings unread

Hey. thx for chiming in..
Im about 80% sure that the issue is with the Clock division in the Sequencer.
Ive been using the G2 slaved from Ableton extensively and never noticed a problem before.

What makes me so sure of this is simply changing the division from 1/96 to 1/16 will fix it.

i spent about 4 hours yesterday messing with the settings and testing things.. specifically the Sync delay on whatever midi interface i use to connect to the Nord.

i have to do this for all my Slaved hardware..

i will however experiment with what you suggest and let you know if it effects things..

it would be a shame if this 1/96 clock is the cause of the error .. i have high expectations of Clavia as their gear has always performed very well for me..

_________________
http://www.materialobject.com
Back to top
View user's profile Send private message Visit poster's website
iPassenger



Joined: Jan 27, 2007
Posts: 1051
Location: Sheffield, UK
Audio files: 5
G2 patch files: 78

PostPosted: Tue Oct 25, 2011 1:52 am    Post subject: Reply with quote  Mark this post and the followings unread

What if you run the two machines from the Nord, one patch based on 1/96 (sent to the left channel), the other based on 1/16(sent to the right channel). Try the two versions both being synced by live and without being synced by live and see if there is a difference? Record both versions of the audio into live.. The Waveforms themselves should give away any weirdness.

If your still having problems you could maybe try syncing the Nord from somewhere else, another machine perhaps (not a computer). I had a lot of problems with sync in my studio until I took the computer out of the equation but you could be right about their being a fault within the Nord.. Just thing you need to narrow down the variables a bit.

Smile

_________________
iP (Ross)
- http://ipassenger.bandcamp.com
- http://soundcloud.com/ipassenger
Back to top
View user's profile Send private message Visit poster's website
ssgrfk



Joined: Oct 21, 2011
Posts: 12
Location: Berlin

PostPosted: Tue Oct 25, 2011 2:04 am    Post subject: Reply with quote  Mark this post and the followings unread

Thats a good idea. ill try that in the near future.
I could also try slaving Ableton to the Nord.
ill let you know the results.

_________________
http://www.materialobject.com
Back to top
View user's profile Send private message Visit poster's website
iPassenger



Joined: Jan 27, 2007
Posts: 1051
Location: Sheffield, UK
Audio files: 5
G2 patch files: 78

PostPosted: Tue Oct 25, 2011 2:18 am    Post subject: Reply with quote  Mark this post and the followings unread

Another thing you could try.

I am not currently online at home at the minute (moving house) but once I am, you could send me the patch and I'll try running them synced to the MD.

_________________
iP (Ross)
- http://ipassenger.bandcamp.com
- http://soundcloud.com/ipassenger
Back to top
View user's profile Send private message Visit poster's website
ssgrfk



Joined: Oct 21, 2011
Posts: 12
Location: Berlin

PostPosted: Tue Oct 25, 2011 2:24 am    Post subject: Reply with quote  Mark this post and the followings unread

Sure.
hit me up when you're back.
I Sold my Machinedrum recently and dont have any other Clock generating hardware at th emoemnt.

_________________
http://www.materialobject.com
Back to top
View user's profile Send private message Visit poster's website
iPassenger



Joined: Jan 27, 2007
Posts: 1051
Location: Sheffield, UK
Audio files: 5
G2 patch files: 78

PostPosted: Tue Oct 25, 2011 3:05 am    Post subject: Reply with quote  Mark this post and the followings unread

ssgrfk wrote:
Sure.
hit me up when you're back.
I Sold my Machinedrum recently and dont have any other Clock generating hardware at th emoemnt.

K.
Ouch! Sinful, why would you do such a thing?

_________________
iP (Ross)
- http://ipassenger.bandcamp.com
- http://soundcloud.com/ipassenger
Back to top
View user's profile Send private message Visit poster's website
ssgrfk



Joined: Oct 21, 2011
Posts: 12
Location: Berlin

PostPosted: Tue Oct 25, 2011 3:09 am    Post subject: Reply with quote  Mark this post and the followings unread

I simply haven't used it in any of my productions for about 2 years.
i think the MD is an awesome piece of gear, but my techniques have changed. and i want the cash for other gear..
Im scoping out that Octatrack thing ..

_________________
http://www.materialobject.com
Back to top
View user's profile Send private message Visit poster's website
iPassenger



Joined: Jan 27, 2007
Posts: 1051
Location: Sheffield, UK
Audio files: 5
G2 patch files: 78

PostPosted: Tue Oct 25, 2011 3:15 am    Post subject: Reply with quote  Mark this post and the followings unread

Ahh fair enough... I had that problem with my CS15, electriBe ER1, Jomox Mresonator loved em all, played with em all but never really used them in a track, cash is more useful at the end of the day... I'd rather have toys that get used in tracks.

Octatrack is great btw. Smile There is room for improvement but it is an awesome machine.

_________________
iP (Ross)
- http://ipassenger.bandcamp.com
- http://soundcloud.com/ipassenger
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [10 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » Nord Modular G2 Discussion
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use